MAC: SAFARI E QUEL LASTPASS CHE NON SE NE VUOLE ANDARE

Posted on 5 ottobre 2012. Filed under: informatica | Tag:, , , , , |

Lastpass, per chi non lo conoscesse, è un comodo servizio “cloud” che si installa come plugin in tutti i browser e per tutti i sistemi operativi, che consente di avere sempre a portata di mano le proprie password ed anche, volendo, di riempire automaticamente i form per l’accesso ai nostri siti personali. Comodissimo e geniale: grazie alla tecnologia cloud, basta installare il plugin in tutti i computer utilizzati, che siano Windows Mac o Linux, per avere la propria cassaforte (come viene chiamata da Lastpass) perfettamente sincronizzata. Ed è pure gratis… purtroppo è a pagamento sugli smartphone. A detta della software house, il sistema è ultrasicuro e nemmeno il server di Lastpass può accedere alle vostre password. Io comunque consiglio di usare una password lunga (quella che imposterete per accedere a Lastpass e sarà l’unica che dovrete ricordare, insieme alla vostra email) e di evitare di usare il servizio per l’accesso a siti veramente importanti quali, ad esempio, internet banking eccetera. Intendiamoci, non ci sono dubbi di sorta sulla serietà e sicurezza di Lastpass, solo che non si sa mai…

Premesso ciò, io uso Lastpass da un bel po’ di tempo e con grande soddisfazione. lo uso su un PC con Windows 7 e con Linux Mint, su un netbook sempre con Windows, su un iMac con l’ultima versione di MacOSX e su un iPad: quindi utilizzo il plugin per Internet Explorer, Safari, Chrome e Firefox. Perfetto in tutti i casi.

Un curioso problema è sorto aggiornando Mac OSX a Mountain Lion e quindi usando l’ultima versione di Safari. Aggiornato il sistema operativo, il plugin di Lastpass non veniva caricato ed all’avvio del browser appariva una finestra con un errore: in sostanza mi veniva detto che la versione di Lastpass (lì per lì non ho fatto caso al numero) non era stata testata con la nuova versione di Safari, per cui per motivi di sicurezza il plugin non veniva caricato. Messaggio, come vedremo, fuorviante e ingannevole. Voi cosa avreste pensato? Un messaggio così, che appare dopo aver aggiornato il sistema operativo, faceva ritenere che Lastpass dovesse essere aggiornato per essere compatibile con la nuova versione di Safari. Vado quindi sul sito e scarico l’ultima release di Lastpass. La installo, funziona, ma all’avvio appare sempre quel maledetto errore. Pazienza! Mi dico che forse la compatibilità non è ancora perfetta e che il problema, a questo punto secondario, verrà risolto con un futuro aggiornamento.

Ma passano le settimane e alla fine mi scoccio di vedere sempre quel messaggio di errore ogni volta che apro il browser. Allora decido di disinstallare il plugin per vedere poi il da farsi: tanto, grazie alla tecnologia cloud,  sarebbe stato sufficiente reinstallare Lastpass per ritrovarmi con la mia cassaforte bella e pronta. 

Ma ecco il colpo di scena: anche senza Lastpass, il messaggio di errore persiste! Mi viene detto che la versione di Lastpass in uso non è stata testata con la versione attuale di Safari, per cui non viene caricata per sicurezza, ma il bello è che Lastapass non c’è più, o almeno così dovrebbe essere!

Allora leggo con più attenzione il messaggio di errore e finalmente realizzo che  si riferisce ad una vecchia versione di Lastpass, la 1.7, mentre quella che io avevo installato era la 2 circa (non ricordo il numero esatto). Ecco perché funzionava tutto! L’errore si riferisce in realtà ad una vecchia versione la quale, in tutta evidenza, ha lasciato qualche traccia che, con l’aggiornamento del sistema operativo, è riemersa dal passato generando il famoso errore. Allora mi metto come un forsennato a cercare nel file system una traccia residua di Lastpass. Trovo pochissima roba, cancello un paio di file  ma niente, il maledetto errore non vuole saperne di andarsene via! 

Alla fine grazie a Google trovo la soluzione nel forum di Lastpass. Sarebbe stata la cosa più ovvia sin dall’inizio, da fare, se il messaggio non mi avesse fuorviato.

Sono andato sul sito di Lastpass, ho scaricato il file di installazione della versione 1.7 (c’è per fortuna un link da cui scaricare le vecchie versioni), ho lanciato l’installazione ma al momento giusto ho scelto la voce “disinstalla”. E l’errore è finalmente sparito.

Annunci

Make a Comment

Rispondi

Inserisci i tuoi dati qui sotto o clicca su un'icona per effettuare l'accesso:

Logo WordPress.com

Stai commentando usando il tuo account WordPress.com. Chiudi sessione / Modifica )

Foto Twitter

Stai commentando usando il tuo account Twitter. Chiudi sessione / Modifica )

Foto di Facebook

Stai commentando usando il tuo account Facebook. Chiudi sessione / Modifica )

Google+ photo

Stai commentando usando il tuo account Google+. Chiudi sessione / Modifica )

Connessione a %s...

  • I’m thinking, please do not disturb!

  • Il mio spazio su Smugmug

  • Immetti il tuo indirizzo di posta elettronica per essere tenuto aggiornato sui nuovi post.

    Segui assieme ad altri 18 follower

  • NO ALLA CENSURA ED ALLE LEGGI SPECIALI PER INTERNET

  • Meta

Liked it here?
Why not try sites on the blogroll...

%d blogger hanno fatto clic su Mi Piace per questo: